2014/03/01

OS X 10.9.2: unload-agents

# 03-1-unload-agents.sh

#!/bin/bash
# 03-1-unload-agents.sh
# OS X 10.9.2
launchctl unload -w /System/Library/LaunchAgents/com.apple.librariand.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.soagent.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.NetworkBrowserAgent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.AirPlayUIAgent.plist

# sharingd -- Sharing Daemon that enables AirDrop, Shared Computers, and Remote Disc in the Finder.
launchctl unload -w /System/Library/LaunchAgents/com.apple.sharingd.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.imagent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.WebKit.PluginAgent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.scopedbookmarkagent.xpc.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.bookstoreagent.plist

launchctl unload -w  /System/Library/LaunchAgents/com.apple.assistantd.plist
launchctl unload -w  /System/Library/LaunchAgents/com.apple.assistant_service.plist

launchctl unload -w  /System/Library/LaunchAgents/com.apple.AirPortBaseStationAgent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.AOSPushRelay.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.icloud.AOSNotificationAgent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.notificationcenterui.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.quicklook.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.quicklook.config.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.quicklook.ui.helper.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.quicklook.32bit.plist

# meta data
launchctl unload -w /System/Library/LaunchAgents/com.apple.metadata.mdwrite.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.spindump_agent.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.VoiceOver.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.ubd.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.syncservices.uihandler.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.syncservices.SyncServer.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.speech.voiceinstallerd.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.speech.synthesisserver.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.speech.recognitionserver.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.speech.feedbackservicesserver.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.speech.speechdatainstallerd.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.SocialPushAgent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.maspushagent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.Maps.pushdaemon.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.screensharing.agent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.screensharing.MessagesAgent.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.RemoteDesktop.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.printuitool.agent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.printtool.agent.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.midiserver.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.mdmclient.agent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.gamed.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.findmymacmessenger.plist

## launchctl unload -w /System/Library/LaunchAgents/com.apple.bluetoothAudioAgent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.bluetoothUIServer.plist
launchctl unload -w /System/Library/LaunchAgents/org.openbsd.ssh-agent.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.java.updateSharing.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.java.InstallOnDemand.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.talagent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.librariand.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.AddressBook.SourceSync.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.AddressBook.abd.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.AddressBook.AssistantService.plist

launchctl unload -w /System/Library/LaunchAgents/com.apple.familycontrols.useragent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.rcd.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.parentalcontrols.check.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.ScreenReaderUIServer.plist

# 2014-03-02
launchctl unload -w /System/Library/LaunchAgents/com.apple.safaridavclient.plist


# 2014-03-05
# 要手動
# launchctl unload -w /System/Library/LaunchAgents/com.apple.identityservicesd.plist

# 2014-03-05
# 下記の追記を pre の中から削除
# 2014-03-03
launchctl unload -w /System/Library/LaunchAgents/com.apple.storeagent.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.store_helper.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.appstoreupdateagent.plist
# 2014-03-03
launchctl unload -w /System/Library/LaunchAgents/com.apple.softwareupdate_notify_agent.plist

# 2014-03-07
# 公開日時の訂正
http://midorex.blogspot.com/2014/03/published-date.html

0 件のコメント: